Jump to content

Bridge disconnects network drives

Recommended Posts

hi Brian, Damien sent me over here - hope you can help!!

For years, I’ve been using Bridge/ACR to access files on my network attached storage (NAS). This has worked flawlessly for me up until a couple of weeks ago when our house suffered a power outage while Bridge was up and running (open to a folder on the NAS). Since then Bridge has turned into a demon spawn and as soon as I direct it to view a folder on the NAS it kills all network access and hangs my machine. The only way to recover is a hard reset. I have uninstalled/reinstalled Bridge and it still has the issue. Bridge works fine if I access files locally – which I figure is what you’re going to tell me I should have been doing all along. But, I’d really like it to get it working with the NAS again as that’s where all my files are. Keeping them locally has workflow, storage, and backup implications – especially if I get a backlog. Soooo, any chance you’ve seen Bridge go wacky and unplug everything and know to fix it?? 😬
Link to comment
Share on other sites

2 hours ago, Ginger Wick said:

Bridge works fine if I access files locally – which I figure is what you’re going to tell me I should have been doing all along.

No, I'm not Damien. :D I work from an External Drive.

I don't think Bridge is the issue. I think there is something else going on, especially with your NAS. Possibly something is wrong with Permissions or Network Shares on your NAS.

What really concerns me is the power outage, do you not have a UPS (Uninterruptible Power Supply) hooked up to your NAS? NAS units should be treated as "Little Servers" and not "Glorified External Hard Drives." (Even though you treat them as such.)
Speaking of which, what type of NAS are you running (Make/Model?) Many support APC UPS Units, and can perform a graceful shutdown when the battery in the UPS gets low. Otherwise files on your NAS or the NAS OS can get screwed up if powered off abruptly.  Like during power outage.

Have you poked around your NAS OS and see if there are any repair tools? What happens when you access a network share through Windows' "Computer" or "Explorer." Do you have Network Shares setup?

  • Like 1
Link to comment
Share on other sites

One more thing, when is the last time you did a FULL Backup of your NAS to either another drive or Cloud Storage? Are you prepared for the whole thing to go ka-plooey and hoping a RAID 1 or RAID 5 Setup will cover your ass? Because it won't. RAID protects you from a single drive (hardware) failure, not data corruption or NAS OS corruption.

Link to comment
Share on other sites

Oh gosh, I am so sorry - I wasn’t notified of a response, so didn’t know you gave one. 

I’ll have to find out from tech support (hubby 🤪) the answers to some of your questions, but in the meantime, yes, I do have drives mapped to the NAS from my machine. I can access them a-okay from file explorer, xplorer2, and photoshop. In my day to day activities, the ONLY hiccup is if Bridge tries to browse those drives. It’s okay for maybe 2 minutes, then it disconnects. And hangs. Entirely. Killing processes in Task Manager doesn’t work. It appears that it just clobbers ANY network traffic, internet too. 

Based on that, I thought the power outage might have zapped my Ethernet cable, so we swapped that out. That didn’t fix the issue.  I’ll test it again, but I think using Bridge to the NAS over Wi-Fi worked, but it was PAINFUL, so I’m currently using it with local files only. 

So I didn’t give you much more info, but I’ll be back later this evening with the specs on the NAS,  if there are repair tools, backup status, and the UPS sitch. 

thanks for your time!! I appreciate it. 

Link to comment
Share on other sites

Okay, here's some more info:

NAS is Synology model DS-418. Didn't see any repair tools immediately visible. All drives reporting normal and healthy. Logs were not enabled, but are now. We don't have a UPS, but one has been ordered. Backups have been running.

Additional weirdness: I tried accessing a (NAS) folder via Bridge, and was poking around for a good five minutes or so (including hitting space bar for full screen previews, and clicking on the image so it would zoom to 100%). All was well. Then I turned on 100% previews and all went to 💩. Did a hard reset in order to get things back in working order. For kicks, after it was back up I unplugged the ethernet cable and ran things over wi-fi. It seems Bridge can access the NAS folders just fine over wi-fi, including generating 100% previews. It's just slower. We have already replaced the ethernet cable. I guess running Bridge over wi-fi is a more acceptable workaround than local folders, but I'd really like it to function as it should/did previously.

Next up is removing the LAN driver and reinstalling it.

Any other things to try/consider? So goofy.

Link to comment
Share on other sites

I'm wondering if your Video Card Drivers are out of date and/or got corrupted somehow. That's what gets hammered when generating 100% full-screen previews. The problem could also be with your Switch that is built into your Router (flaky port) or LAN Drivers isn't a bad idea. Try using a different port on the Switch. Oh, you are going to want to watch this video:

Synology NAS UPS Setup Guide

That video does a pretty good job walking you through the steps.

Anyway, I'm wondering that since Wi-Fi is slower than hard-wired Ethernet, that the lag is somehow helping Bridge keep up? I also found this:


Might want to go through the steps, as there doesn't seem to be any kind of true Diagnostic Scan with your NAS, but there are some things that allow you to verify things.

One more thing...

Do you have another computer or laptop that you could try? Just to see what happens. It could be a problem with your PC, that's why I have UPS units on ALL of my electronic equipment, from computers to my home theater system. Even my Wireless Access Point is on a 400VA UPS.  My wife wasn't thrilled with her UPS being one of her Xmas Presents, but after the power glitched for a few seconds over the last few months, she was grateful to have them.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...