Jump to content

Can't open photos at all in elements 14/15 or CC


 Share

Recommended Posts

Hello, I looked and didn't find this question listed.  I have an IMAC and it upgraded to Sierra on it's own upon shutdown, not sure how it did that as I'm the only one who used it.   I can't open any RAW photos at all with either elements 14 (my own) trial of 15 or trial of CC.  It won't let me right click on any RAW to open them.   I can open them in LR5 and then edit in Elements 14.  Any ideas on a solution on how to fix this?    

Neither Applecare or Adobe had a solution

Link to comment
Share on other sites

So how do you normally open the photos? Do you copy them to a folder on the HD and then open them? Or do you use some sort of special software for the transfer?

 

On 3/7/2017 at 3:44 PM, Candice Penna said:

I can open them from the sd card and the photos are the same

Huh?

I'm assuming things work as they should when opening the files directly on the SD card?

Link to comment
Share on other sites

iPhoto, and its Demon-Spawn Child, "Photos" is EVIL. It gets in your way. I'm glad you are straightened out. I completely forgot about Photos / iPhoto.

Link to comment
Share on other sites

Hi Damien, 

 I am back on track with the RAW class.  I was in an extensive search for my husband's birth father so I had to put this class on hold.  Can you tell me where I can find the link again for the class, I would like to read everything from the beginning.  Thank you, Candice Penna 

Link to comment
Share on other sites

The classes are below the Ask Brian section here on the website. Just head to the main page and if you are green-lit into the class, you should see it on the main page. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...