Jump to content

Screen changes when laptop plugged in vs unplugged


 Share

Recommended Posts

I calibrated. Awesome. Prints match my screen. Perfect! Then I go to edit a photo from one of my test prints and it looks totally different. I realize that my screen changes if it is running on battery power. If I plug it in the colors go back to being correct. How do I stop the madness?

 

Toshiba Satellite lap top running Windows 8

Link to comment
Share on other sites

It turns color and also less contrast. It does not go to power saving mode on battery. Screen brightness is the same. Would it be helpful if I attempted to take a photos of the screen?

Link to comment
Share on other sites

I observe this on my laptop too, but to my eye it's a brightness shift.  If it really is a brightness issue, there could be a solution to your problem here:

http://superuser.com/questions/471073/how-to-prevent-laptop-screen-brightness-from-changing-when-un-plugging-battery-p

The process is to enable Powershell commands, make a script (i.e. copy text into a notepad file), save the notepad file in your Windows folder and make a shortcut in your Startup folder.  The script ensures that even if the power source changes, the brightness of the screen will not change.

So sign in as an administrator and follow these steps:

1. Run Powershell (search your computer for "Powershell"  and run the desktop app).  Check your current Powershell policy setting by typing Get-ExecutionPolicy.  It will probably return the result Restricted.

2. Change Powershell policy to Unrestricted by typing the command Set-ExecutionPolicy Unrestricted  (More info here: https://technet.microsoft.com/en-us/library/ee176961.aspx).  This will allow the script to run, otherwise it will be blocked.

3. Make a notepad file containing the script.  It looks like you need to combine the two scripts on that superuser thread (copy the script text from user Jacopo Irace's answer, then DrNT007's answer).  My notepad file ended up looking like this:

Script.thumb.JPG.b25b0573ed58184c1345958

4. Save this file into your Windows folder.  Give it a file name with no spaces in it and make the extension of this file ".ps1"  Make a shortcut to this file in your Startup folder.

If you try it and this doesn't fix your problem, reset your Powershell policy:  go back into your Powershell desktop app and change your settings back to Restricted by using the command Set-ExecutionPolicy Restricted.  And you can delete that script file if you want to.  

  • Like 2
Link to comment
Share on other sites

Sounds similar to what my Lenovo Yoga 13 (and thousands of other users) experienced.

I'm assuming you have an Intel graphics chip on that system.  Assuming that, Intel has its OWN power saving settings along the lines of Adaptive Brightness/Contrast.

Take a look at:  http://answers.microsoft.com/en-us/windows/forum/windows_8-desktop/how-do-you-completely-disable-adaptive-brightness/b0161873-4ebb-4070-bdad-fdcc01f17e16?auth=1

Also... Toshiba just announced a recall for certain Satellite, Tecra and other model systems manufactured between 2011-2016.  Have a look for more information on that (which is not related to your issue, but a concern) here: https://batterycheck.toshiba.com/?region=TAIS&country=US&lang=en

Hope this helps somewhat.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...